wordpress 5.4.1,如果你下载提示429 too many requests错误的解决办法

  • wordpress 5.4.1,如果你下载提示429 too many requests错误的解决办法已关闭评论
  • A+
所属分类:主题源码

wordpress 5.4.1,如果你下载提示429 too many requests错误的解决办法
从5.4到3.7,安全修复程序已添加到WordPress的每个主要版本中。解决了以下漏洞:

.wordpress 5.4.1,如果你下载提示429  too many requests错误的解决办法

  • 密码重置令牌未正确无效。
  • 某些私人帖子无需身份验证即可查看。
  • 定制程序中的两个跨站点脚本(XSS)漏洞。
  • XSS问题在搜索块中。
  • WordPress对象缓存中的XSS问题。
  • 文件上传的XSS问题。
  • WordPress 5.4 Release CandIDAtes 1和2的块编辑器中的XSS问题(在5.4 RC5中修复)。

古腾堡(Gutenberg)插件移植到WordPress 5.4.1发行版以来,几个修复程序的优先级都很高。面对用户的最大问题是重复块键盘快捷键损坏,按钮块未对齐以及尝试在长块中编辑文本时滚动行为异常。
以下是开发团队解决的问题的完整列表:

  • 修复了用于复制块的Ctrl Shift D键盘快捷键,该快捷键不再引发错误。
  • 向左或向右对齐按钮块时添加正确的边距。
  • 单击以编辑大块(例如长列表)时,防止编辑器滚动到顶部。
  • 不再为在工具栏中具有文本输入的插件隐藏工具栏。
  • 当图像缺少尺寸时,使用最新的帖子块停止JavaScript崩溃。
  • 转义RSS和搜索块的HTML类以防止格式错误的标记。

其他WordPress核心变更如果用户还使用核心WordPress网站图标,则以暗模式运行浏览器的用户会感到很高兴。该团队引入了一个带有浅色背景的更新的图标,以便不再被冲洗掉。这是次要的修复程序,但是使著名的WordPress徽标看起来更加专业。
以前设置为的标题级别

已在WordPress管理员自由屏幕()上提高了一个级别wp-admin/freedoms.php。此项更改提供了适当的标题级别,并应有助于屏幕阅读用户更好地浏览页面。
对于无法在媒体库中选择文件的Edge或iOS Safari浏览器上的用户,这是由于CSS问题隐藏了输入。在新的更新中,这不再是问题。
WordPress 5.4.1解决了先前版本的一些回归问题。一种是围绕没有添加标题的情况下通过电子邮件发布。在这种情况下,应该使用电子邮件主题作为标题,但是由于WordPress 5.4中的代码更改而被打破。对于开发人员来说,category_link和tag_link过滤器钩子以前被错误地弃用,现在又可以很好地使用而不会发出通知。
插件开发人员有一些错误修复可以期待。WP_Site_Health现在在plugins_loaded和after_setup_theme钩子之后实例化该对象,这意味着它们可以在检查站点运行状况之前执行必要的操作。现在,已弃用的wp_get_user_request_data()函数已正确加载到前端,这导致了诸如BuddyPress之类的插件出错。
在较大的设计更改中,向隐私策略指南添加自定义内容的插件作者可以使用更多HTML元素。在WordPress 5.4中,指南设计已更新,在建议的文本后面添加了白色背景。但是,新代码仅适用于段落。现在,该设计支持表格,列表和其他常用元素。无序列表也有项目符号要点,以区别于段落。
开发团队修复了REST API的两个问题。第一个解决了get_item权限检查的问题。第二个修复了_fields过滤。现在,核心代码使用该rest_is_field_included()函数来确定要包括哪些字段,以允许按嵌套字段属性进行过滤。安全更新
六个安全问题影响WordPress 5.4及更早版本;版本5.4.1修复了这些问题,因此您需要升级。如果尚未更新到5.4,则还有5.3和更早版本的更新版本可解决安全问题。

  • 对  Muaz Bin Abdus Sattar  和  Jannes的支持  ,他们分别报告了密码重置令牌未正确失效的问题
  • 为  ka1n4t提供支持,  以查找某些未经身份验证即可查看某些私人帖子的问题
  • Evan Ricafort  在定制程序中发现XSS问题的道具
  • WordPress安全团队的Ben Bidner的道具,他在搜索块中发现了XSS问题
  • WPVIP.com/WordPress安全团队的Nick Daugherty的道具在wp-object-cache中发现了XSS问题
  • Ronnie Goodrich(Kahoots)和  Jason Medeiros的道具, 他们在文件上传中独立报告了XSS问题。
  • 此外,Nguyen Duc在WordPress 5.4 RC1和RC2中发现了块编辑器中经过身份验证的XSS问题。它已在5.4 RC5中修复。我们希望确保给予赞赏,并感谢他们为使WordPress更安全所做的所有工作。

维护更新
WordPress 5.4.1还修复了5.4版中引入的一些回归:

  • #49838 –可访问性:修复“自由”页面上的标题层次结构
  • #49798 –自定义:为深色模式浏览器赋予WordPress徽标白色背景
  • #49853 –邮件:使空帖标题的检查  wp-mail.php 更具弹性
  • #49753 –媒体:display: none;从Plupload中使用的(隐藏的)按钮中删除,以选择要上传的文件。修复了在Edge <= 44和iOS Safari中选择文件的问题
  • #49772 –隐私:在隐私政策指南的新样式中支持其他元素(表格,ol,ul)
  • #49802 –隐私:wp_get_user_request_data()在前端提供不推荐使用的功能
  • #49645 – REST API:修复了修订版控制器的get_item权限检查
  • #49648 – REST API:修复_fields对注册的休息字段的过滤
  • #49824 –网​​站运行状况:实例化可防止插件使用某些挂钩
  • #49759 –分类:弃用category_link和tag_link过滤
  • #49974 –块编辑器更新
  • 【国内分享下载地址】https://yongwp.lanzous.com/ic3t9ra安装/更新信息
    要下载WordPress 5.4.1,请从站点管理区域中的“仪表板”>“更新”菜单自动更新,或访问https://wordpress.org/download/release-archive/。WordPress 5.4.1解决了7个安全问题并修复了多个错误